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When there are too many data in the database after few years. Some of the user would request for database

purging in order to remove previous year data and have a new financial period in

1. Check Financial Period, for example this database is start from 1/1/2011 to 31/12/2011

View Tools Inguiry Maintenance

B s = [0 o

2zt o [

Fojects Finandal Valid Posting Default Interface Currencies Terms Areas  System  Running Posting
Period Periods Accounts Options Numbers Account Groups
Maintenance
% Financial Period
M Financial Period
Fiscal Start Year 2011 Account Start Year
Fiscal Start Month 1  Account Start Month
Length Of First Fiscal Period 12 Cutoff Date
From 01/01/2011 -
To 31/12/2011 =

system

(A

User Default
Form Format

01/01/2011

2. To proceed year end, go to Tools > Database Utility > Year End Processing

ONE Business Solutions

Inquiry Maintenance

ALAE Data Device Database Bug Report Purge Audit Data Integrations Remote Update Server Connected

Export  Settings Upgrade History Trail b Support  Credential Users
Tools

Navigation [z x

Dashboard

nlilul Overview
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Clear Database
Transactions = Utility +

Databz L

W @ e

Backup

Restore

Schedule Backup
Database Utility

Year End Processing
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3. System will request to perform backup first.

@ Year End Processing

Your are highly recommendead to do the backup before the Data Purge¥ear End
Clasing. Do you want to backup now?

Already have a backup, Continue Backup Mow

Note: How to Backup

https://support.qne.com.my/support/solutions/articles/81000383845-how-to-backup-optimum-

4. Click Continue the year end step after backup.

Step 1: Backup your current database(eg, SampleDb)

Step 2: Restore the backup to a new database(eg, SampleDb2020

Step 3: Clear transactions and set cutoff date

Step 4: Migrate outstanding transactions from current database(SampleDb) to new dtabase(SampleDb2020)

r_iDone

Done

Done

Done

Close



https://support.qne.com.my/support/solutions/articles/81000383845-how-to-backup-optimum-
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5. Tick done for Step 1 Backup.

Vear End Processing

Step 1: Backup your current database(eg, SampleDb) [~| Done

Step 2: Restore the backup fo a new database(eg, SampleDb2020) [ ] Done

Step 3: Clear transactions and set cutoff date Done

Step 4: Migrate outstanding transactions from current database(SampleDb) to new dtabase(SampleDb2020) =~ Dene

6. For step 2, system requets to restore the database. This database will keep as a “Source database”. It
allows you to perform a migration of the outstanding transaction later at step 4. Besides, you can
name it as “Original Database” whicg allow you to double check or compare the data before year end
and after year end

Database Restore

Destination
Server Mame |F‘C 106YQMEBSS -
Authentication
(®) System Authentication () Windows Authentication () 5L Authentication
User ID | SA Password FEEEEEEES |
Database |SampIEDBED21EIEI4_rES1J:|rE = | | Test Connection

Connection String |Data Source =PC 106YJMNEBSS; Initial Catalog=5ampleDE2021004_restore;Integrated Securi... -

Restore From |D: \OnEBackup'\SampleDE2021004_ 202201061623 2021004, gnebak |

Password | |

P =
@ Restore @ Close

Note: How to restore database
https://support.qne.com.my/support/solutions/articles/81000391002-how-to-restore-database



https://support.qne.com.my/support/solutions/articles/81000391002-how-to-restore-database
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7. Tick Done for Step 2 Restore the backup database.
Continue for step 3 to perform Clear transactions. Set the cutoff date you which to begin. The sample
below cutoff date as 1/1/2021. Means system will clear the database from 1/1/2011 to 3112/2020

Year End Processing

Step 1: Backup vour current database(eqg, SampleDb) ] Done
Step 2: Restore the backup to a new database(eg, SampleDb2020) [| Done
Step 3: Clear transactions and set cutoff date [ | Done
Step 3: Year End Clesing

Connect to the new database you want to setup

Server Name | PC106\JMERSS -
Authentication
(@) System Authentication () Windows Authentication () QL Authentication
User ID |SA Password s |
Database | sampleDB2021004 - | [ Test connection

Connection String |Data Source=PC 106\GMEBSS; Initial Catalog=5ampleDB2021004;Integrated Security =False;User ID=5A;Password="*"****%Connect ... -

Account Start Period

Account Start Year | 2021 - | Account Start Month 1.
Cuteff Date 01/01/2021 -

Hint:
System will purge transactions before cutoff date.
Please continue step 4 to migrate outstanding transactions from past fanancial years after puraing.

| Close |
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8. Click Purge Data.
Step 3: Year End Closing
Connect to the new database you want to setup
Server Name | PC106\QJMEESS -
Authentication
() System Authentication () Windows Authentication () sQL Authentication
User ID |SA Password SRR |
Database |SampIeDBZIJEIDD4 ~ | | Test Connection

Connection String |Data Source =PC 106 YQNEBSS; Initial Catalog=SampleDE2021004; Integrated Security =False;User ID=5A;Password="*%%*_ ~

Account Start Period

Account Start Year | 2021 | Account Start Month 1 2
Cutoff Date 01/01/2021 -

Himt:

System will purge transactions before cutoff date. Purge Data

Please continue step 4 to migrate outstanding transactions from past fanandial years after purging.

9. System will prompt message as below if there is any document yet to knockoff

You can check below reports, these reports show that those Receive Payments / Pay bills / Credit
Notes / Journal Vouchers have been created but yet to knockoff, system will prompt a reminder you to
complete it first

You can find the report from:

View > Reports > Supplier Reports > Master Reports > Supplier Open Credit Listing

View > Reports > Customer Reports > Master Reports > Customer Open Credit Listing

Click Yes if you want to continue

r End Purging b 4

m
]

There are some documents not fully knockoff, please refer to Customer /Supplier Open Credit Listing Report for details.
Do you want to continue with the purging?
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10. Next, system will prompt remind message if there is any outstanding document in Purchase, Sales and
Stock Module transactions. Transactions can define as outstanding:

Purchase Requisition, Purchase Order, Goods Received Notes
Quotation, Sales Order, Delivery Order
Stock Outs

If the above transactions created but without full transfer, and the status is still open system will
prompt message as below

Example if you have created Purchase Requisition but not yet transferred to Purchase Order due to
some reason, system will still remain as outstanding.

Thus, you need to close these documents.

Refer to this link on how to close the Outstanding document.
https://support.gne.com.my/support/solutions/articles/81000387776-sales-and-purchase-module-one-by-one-document-mark-
as-close- and-mark-as-close-by-batch

Note: System will check the outstanding transaction within the purging period

It is advised you can check below documents to find out the outstanding reports and then close it so

that system will not keep unnecessary documents in the new database
View > Reports > Purchase Reports > Outstanding Purchase Requisition

View > Reports > Purchase Reports > Outstanding Purchase Order

View > Reports > Purchase Reports > Outstanding Goods Received

View > Reports > Sales Reports > Outstanding Quotation

View > Reports > Sales Reports > Outstanding Sales Order

View > Reports > Sales Reports > Outstanding Delivery Order

View > Reports > Stock Reports > Outstanding Stock Outs

Notes Click No if there is no any outstanding document and you want to further proceed

There are some Outstanding document in Sales / Purchase / Stock.
Would you like to dose those document which having Outstanding or not ?

Yes No
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Yea
Connect to the new database you want to setup
Server Mame |PC 106\QMEBSS -
Authentication
(@) System Authentication () windows Authentication () sQL Authentication
User ID |SA Password FEEm——— |
Database |SampleDBZDZlDD4 Purge Data S - | Test Connection
Connection String |Data Source=PC 106YQNEBSS;Initial Catd] Data purging completed successfully, /=False;User ID=5A;Password="*****=*=Connect ... =~
Account Start Period
Account Start Year | 2021 | Account Start Month 12
Cutoff Date 01/01/2021 -
Hint:
System will purge transactions before cutoff date. Purge Data
Fleaze continue step 4 to migrate outstanding transactions from past fanancial years after purging.
| Close |

12. Check the financial period, system will start from 1/1/2021 now. All transactions before 2021 has been
removed.

A5 Financial Period

Fiscal Start Year 2021 Account Start Year 2021
Fiscal Start Month 1 Account Start Month 1
Length Of First Fiscal Period 12 Cutoff Date 01/01/2021 -
From 01012021 -

To 31/12f2021 -
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13. Continue the year end step for step no. 4 to migrate the opening balance & outstanding documents

Step 1: Backup vour current database(eqg, SampleDb) [] Done
Step 2: Restore the backup to a new database(eg, SampleDb2020 /] Done
Step 3: Clear transactions and set cutoff date [+] Done

Step 4: Migrate outstanding transactions from current database(SampleDb) to new dtabase(SampleDb2020) [ |pone

14. Migrate those outstanding document to the system > Click on Optimum

Import From

UBS 9.0(Fox Pra)

QME(Firebird)

Excel Templates

QME Optimum

SQL Account (Firebird)
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15. Search the database as the working database. The database which you perform for year end

& Migration Wizard — O >

Your working database
Connect to the new working database you want to setup

ServerName  |PC106\QNEBSS -| =
Authentication
(®) System Authentication () Windows Authentication () 50L Authentication
User ID |SA Password m—— |
Database |Sam|:|IEDB?_DZIDD4 '| Test Connection

Connection String |Da13 Source =PC 106\JMNEBSS; Initial Catalog=5ampleDB2021004;Integrated Security=False;User ID... = | |Z|

DocNo :1 Page No: 10/14

< Back Mext = | | Cancel

16. Then, choose the source of database which we restore at step 6 just now.

& Migration Wizard — O o

Your import data
Select your source of data

Data Provider | Optimum Database

ServerName  |PCI108\QNEBSS -
Authentication
(®) System Authentication () windows Authentication () 50L Authentication
User ID |SA Password T |

Database |SampIED82DZIDD4_resbJrE - | Test Connection

Connection String |Daiﬁ Source=PC 106 \QMNEBSS; Initial Catalog=5ampleDE2021004_restore;Integrated Security=Fals... = |

< Back || Mext = || Cancel
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17. Tick the table you would like to migrate. Click Import

From here you can see, system allow you to migrate
v" GL opening balance
v" AP opening balance
v" AR opening balance
v' Stock opening balance
v" Bank Reconciliation opening balance
v' Month End Stock Value
v' Outstanding Purchase Requisition, Outstanding Purchase Order, Outstanding Goods Receive Notes
v" Outstanding Quotation, Outstanding Sales Order, Outstanding Delivery Order

v" Outstanding Stock Outs

Ready to import
Review your settings and dick IMPORT to continue

v Report Date | 31/12/2020 -~ CutOffDate | 01/01/2021 B

b v Past Invaices Log
Past ARDN

v Past ARCM

Past AR Receipt

o AR Matched Data

4

4

v Past Bills

v Past AFDN

" Past APCM

+ Past AP Payment

" AP Matched Data

v GL Opening Balance

v Bank Recondliation OB

Manthly Stock Value

4

Overwrite Data

IMPORT
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System will display as Complete if the import is successfully > Click Finish and Close all the screens

Migration Wizard

Ready to import

Past Invoices - 9393

Past ARDN - 5/5

Past ARCM - 15/15

Past AR Receipt - 14/14

AR. Matched Data - 0/0
Past Bills - 53/53

Past APCM - 2/9

Past APCM - 15/16

Past AP Payment - 11/11
AP Matched Data - 2/2

GL Opening Balance - 43/43
Bank Recondliation OB - 98...
Manthly Stock Value - 00

“
LA LK

Overwrite Data

IMPORT

Review your settings and dick IMPORT to continue

ReportDate | 31/12/2020 - CutOffDate | 01/01/2021

Log
Importing Past Invoices...Complete!

Importing Past ARDN...Complete!
Importing Past ARCN...Complete!
Importing Past AR Receipt...Complete!
Importing AR Matched Data...Complete!
Importing Past Bills. .. Complete!

Importing Past APDM...Complete!
Importing Past APCM...Complete!
Importing Past AP Payment...Complete!
Importing AP Matched Data...Complete!
Importing GL Opening Balance...Complete!
Importing Bank Recondliation OB...Complete!

Importing Monthly Stock Value. ..Complete!

< Back Finish

Cancel
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18. Go back to the login screen of working database

Click Ctrl + U, system prompt below message, click YES

A

Database Mannual Upgrade

f
AN

This functionality is intended to provide support for technical person only.
Do you wish to continue at your own risk?

QNE Bus

Version: GAFv2. ;

(Build: 2021.0.0

# Sample Co
== [PC106\QNEBSS::SampleDB2021004]
@ [localhost:10010]

Account Date: ([UNVP7aNERd B Save Account Date

19. System will update something you can continue to login the system

20. If you search Purchase Requisition / Purchase Order / Goods Received Notes / Quotation / Sales Order
/ Delivery Order, those outstanding transactions will be migrated and it will display as “Past Entries” in

the transactions.

ﬁ pU rChase Req ulsltlons (Past Entries)

Detais | Suppher | Deliver To | Others | Notes | [*] Files | Approvals | Info

Supplier 500-D001
From  |DELL ENTERPRISE SDN. BHD.

-| Currency  AM
VINCENT

Term 60 DAYS = Purchaser ALVIN
Location - Require Date
Project

=) View Variants »

(| n Ie m X v e & © O® g~ »

» 1 IMTCOROM IMATION 52X CD ROM 10 UNIT 55.00

2 QMNEPREM QME ACCOUNTING SYSTE 10 PACKAGES 10,99

Rate

Doc Date

08/0+/EE0

" | Requisition No. PRO101/002

" | Reference Mo.

Tax Indusive
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21. The year end processing is completed. Next, you can continue to compare below report with using the
working database and source (original) database. The purpose of this checking to ensure the result are tally
after year end.

v' GL Opening Balance

v Balance Sheeting report as at the year end closing date. For this scenario, it will be 31/12/2020
v Customer Aging report as at the year end closing date. For this scenario, it will be 31/12/2020
v Supplier Aging report as at the year end closing date. For this scenario, it will be 31/12/2020

v" Month End Stock by Location as at the year end closing date. (If you do not use Location, you can view
Month End Stock Report) For this scenario, it will be 31/12/2020

v Outstanding Purchase Requisition
v Outstanding Purchase Order

v" Outstanding Goods Receive Notes
v" Outstanding Quotation

v" Outstanding Sales Order

v Outstanding Delivery Order

v" Outstanding Stock Outs




